Which browsers do we support?

Kiwibank Internet Banking is optimised to run on:

  • Internet Explorer 8 or newer (IE 8+)
  • Firefox 29 or newer
  • Safari 6 or newer
  • Chrome 34 or newer

JavaScript and cookies must be enabled to use Kiwibank internet banking

If JavaScript is not activated, you’ll see a message when you try to log in. JavaScript is normally on by default in out supported browsers. If you see this error message you can activate JavaScript.


How do I know which browser version I’m using?

To check which browser you’re using, open the browser and either click the ‘Help link’ or the ‘settings icon’, then select the ‘About’ browser option (eg, ‘About Internet Explorer’, ‘About Google Chrome’).


What if I don’t use the supported browsers?

Although we only support the browsers listed above, many other unsupported browsers will still work (eg, Opera Mini 6, Android Dolphin, Safari 5, Firefox 3.6, IE7) – but unsupported aren’t fully tested, so certain parts of the site may not work perfectly or may not be secure.

If you’re having technical issues and you’re not on a supported browser, we recommend you download one of these browsers:

Please note: Microsoft no longer supports operating systems than Windows XP (including Windows 2000, Windows 98, and Windows Me). Systems that aren’t supported aren’t kept up-to-date with the latest security updates, so they may not be secure.

If you’re using a Microsoft operating system older than Windows 2000, it’s possible that you won't be able to install our supported browsers.


Why don't we support other browsers?

Once a browser meets or exceeds a 5% threshold we’ll support it.

Related pages